Dependencias Desactualizadas

En la publicación anterior sobre Laravel/Breeze te comentaba como había tenido un pequeño problema al no tener la versión más reciente de Php. Laravel/Breeze se instaló bien, pero cuando quiero usar npm run dev da otro error, no puede compilar lo que está en app.css.

El error no dice la gran cosa, solo un montón de rutas en color rojo 🙄 a ver que dice Don Google…(se me olvida tomar captura de los errores, prometo mejorar en eso.)
Dice que puede ser la extensión postcss, deshabilité la extensión en el archivo webpack, pero el error continúa…

Trato de ver más detalles dentro del mensaje de error y encuentro:
TypeError: [(…variantsValue),(…extensions)].flat is not a function

Qué pasó? … Luego de buscar información al respecto encuentro lo siguiente: Array.prototype.flat is indeed supported from NodeJS 11.x and up

Tenía la versión 10.x …

Imagen

Siempre recuerden actualizar todas sus herramientas y dependencias dentro de los proyectos y procuren hacer esto antes de iniciar, se ahorrarán mucho tiempo al momento del desarrollo.

Image by Hans Braxmeier from Pixabay

Compartir

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *