Laravel/Breeze … un error

Laravel/Breeze es parte de los «Starter Kits» de Laravel para implementar autenticación en tu sitio web. Todo muy lindo hasta aquí y no es que no funcione, el problema fui yo.

Laravel/Breeze me tiraba un error al tratar de descargarlo via composer:

composer require laravel/breeze --dev

Y no dice nada, solo que hay incompatibilidades.

Entonces me voy a buscar más info sobre el paquete. Al revisar en packagist me encuentro que necesita php: ^7.3|^8.0
Genial, yo tenía el 7.2, además de eso necesita dos paquetes de illuminate.

Bueno, no pasa nada, actualizo la versión de php y ya.

Pues no mi ciela, tuve reinstalar todo el Xampp (esta es la herramienta que siento que a mí me resuelve mejor en Windows).

Ya con la versión más reciente de Php y MySql, no debería haber problema. Que sad, no fue así. Resulta que Laravel instala la versión que sea la más apropiada para tu entorno, claro como yo tenía una versión de Php algo obsoleta entonces la versión de Laravel que se me instalo era la 6.x y Laravel/Breeze necesitaba paquetes que no estaban en esa versión, los paquetes que les mencionaba antes (illuminate).

Intenté hacer únicamente composer update pero no funciona así 😉 así que tuve que instalar Laravel de nuevo, en mi caso esta fue la opción más útil porque apenas estaba empezando el proyecto, pero en realidad no sé si hay una forma más fácil de hacerlo si perder los avances que ya tengas listo, pero voy a investigar al respecto.

Una vez que tenía Php con la versión más reciente, pude descargar Laravel via composer con la versión correcta. Ahora sí, está listo 🙂

Image by confused_me from Pixabay

Compartir

2 comentarios en «Laravel/Breeze … un error»

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *